Bitdef Last Update Messed Up My Pcs

6 posts in this topic

I'm a BitDef user since 2005 and used to say that I was a happy user - my PC-s were always clean and protected, and since nobody else messes up with my computers (two desktops and a laptop), if there was an error, I was usually able to resolve it it no time.

Well, until now, when this update from BitDefender messed up everything - and it took me some time to figure it out, because I've looked all around the PC, as I didn't even suspect the reason could be BitDefender.

Looking at the forum posts, I'm not the only one - after update, one of my desktops couldn't open any websites (it was the same in Firefox, IE and Opera). Then the errors began - BitDef critical error, then the "Can not update error", registry control was popping-up all the time with some weird questions. When I opened "Your Uninstaller" registry control popped out all kind of random weird characters...

When I discovered the BitDefender update error, I finally looked for solution at BitDef support (but not yet at the forum) - I did a repair of BitDefender and applied the fppatch.exe downloaded from the site. It seems to fix some of the errors - BitDefender on my desktop now updates, I can open websites in all browsers, but I suspect there is more to it then that, didn't have time to test it throughly.

Today my laptop started popping-out errors - BitDef can't update and pops-out a critical error. I can't connect a USB disk - there is a yellow exclamation mark in Device Manager under "USB mass storage device". My laptop lost sound - it starts as if it's all ok, but if I click the sound icon in tray, the volume control won't open - the sound properties in contol panel claims there is "no playback device".

I first tried to apply the simplest solution, found on this forum, and replaced the C:\Program Files\Common Files\BitDefender\BitDefender Update Service\v_live_s.xml file with the one found in the C:\Program Files\BitDefender\BitDefender 2010\Ini\Default folder. Nothing.

I then tried to populate the log file as described in Topic16543 - after I type supporttool.exe /livesrvtrace at the command prompt and press enter no pop-up asks me to reboot - and I can't update, and there is no mentioned livesrv.log in All Users\Application Data\BitDefender\DTrace\ folder.

Without repairing the BitDeffender, I tried to apply the same patch mentioned before (fppatch.exe), but this time it didn't help - the sound is back, but I still can not connect the USB disk, and I still can not update - this time is Invalid MD5 error. And my laptop won't perform system restore.

Now I'm affraid to power up my third PC - BitDefender is set to start right away performing an update, and I really don't want to find out what will go wrong this time.

So, BitDefender managed to mess up my PCs more than any virus, malware or poorly coded software (or even a computer illiterate human) did in the past years.

Hope this fix announced for the end of this week (by the way, its friday tommorow) will do the job.

I paid for BitDefender to be able to work on my PC (and I have to meet the deadlines - as other users probably too), and not to spend time fixing it.

Share this post

Link to post
Share on other sites

I have the same problem with the USB. I disable the registry control in Bitdefender and the USB works. You could try that until they fix the problem.

Share this post

Link to post
Share on other sites

Found a new problem - by doing a repair install of BDIS 2010 i thought I've managed to, at least partially, solve the problem with sound and USB, and I can browse the net. It seemed that BDIS is updating - each update "installed successfully" - but I've noticed that each update shows "total update" should be 60440 KB and "downloaded" was 35 KB, (the engine version also didn't change - it always shows 7.27707, and it occured every time I tried to update.

Then I followed the advice from the forum and set the update settings to "prompt before downloading updates" both for automatic and manual updates. The pop-up showed there is a virus signatures update of 60440 KB - i click OK, but the message if I want to install it just popped up again - three or four times - at the end there was the "MD5 error" again.

I've set it again to do silent updates, and there it was again - "update successfully" with just 35 out of 60440 KB.

Finally I downloaded the "weekly.exe" update, and tried to install it - after a while it pops-up a message that "the installer has insufficient privileges to modify the C/Program Files/Common Files/Bit Defender/Bit Defender Threat Scanner/av32bit_000/Plugins/TBD9.tmp" - it is a 0 b file, but it won't let me set the full control for my username (I have admin privileges).

Share this post

Link to post
Share on other sites

Hello Vespera,

As Nick20 said, try to disable the Registry Control temporarily and look if the same issues occurs with your sound card and USB devices. In order to do this, open BitDefender in Expert Mode, click on the Privacy Control module, select the Registry tab and temporarily disable it.

Also, in order to investigate this sittuation, we would like you follow the instructions described here and send me a PM with the download link of the Support tool report.

We also want to inform you that my colleagues from the Testing team are aware of this sittuation and they are currently investigating it.

We are sorry for any inconveniences caused by this issue .

Thank you.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now